News : ATI Catalyst Graphics Drivers 9.11 Released

Looks like AMD was waiting for Fedora 12 : Constantine release. AMD has released the next version 9.11 of ATI Catalyst Display Drivers. The drivers can be download from ATI Catalyst™ 9.9 Proprietary Linux x86 Display Driver Page. I have downloaded and tested them already on my machine with ATI Radeon HD 3200 (onboard) card with kernel 2.6.29.6-217.2.8.fc11.i586. This version is supposed to work with 2.6.30+ kernels as even 9.10 was working. So, if you have already installed Fedora 12, don’t waste time. Test the drivers and let us know :)

Note1 : Installation Process : How To: Install ATI Catalyst (fglrx) 9.8 Drivers on Fedora 11.
Note2 : Dual Display Configuration : How To: Configure Dual Display with ATI Radeon (fglrx).

 

32 thoughts on “News : ATI Catalyst Graphics Drivers 9.11 Released

  1. Any ideas as to what I’m doing wrong? I am very new to Linux (installed it yesterday for the first time, Fedora 12). I downloaded the drivers for my HD4850 and can’t seem to install them. Here’s the Terminal window text:
    [Wes@localhost ~]$ su
    Password:
    [root@localhost Wes]# $ bash ./home/Wes/Downloads/ati-driver-installer-9-11-x86.x86_64.run
    bash: $: command not found
    [root@localhost Wes]# /home/Wes/Downloads/ati-driver-installer-9-11-x86.x86_64.run
    bash: /home/Wes/Downloads/ati-driver-installer-9-11-x86.x86_64.run: Permission denied

    1. Hello Wes,

      did you add execute permission to the downloaded file? Try the following commands:

      su
      cd /home/Wes/Downloads
      chmod +x ati-driver-installer-9-11-x86.x86_64.run
      ./ati-driver-installer-9-11-x86.x86_64.run

      HTH,
      Mx

    1. You Xorg.log file says,

      (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so
      (II) UnloadModule: “fglrx”
      (EE) Failed to load module “fglrx” (loader failed, 7)
      (EE) No drivers available.

      That means, the drivers were not installed successfully.
      Try again.

      1. Thanks for the reply, but I did check the Catalyst install log and everything is fine. Plus, I already tried to reinstall it several times and it’s still not working.

        Also, according to this link, Catalyst 9.11 is incompatible with Xorg 1.7 :(. I’d better off installing radeonhd then :(

  2. wes: you need to do ‘chmod +x’ on the file first, or run ‘sh /home/Wes/Downloads/ati-driver-installer-9-11-x86.x86_64.run’ , without the $ sign or the ‘.’ in the command.

    Kulbir, I think the X.org server version may potentially be more of a stumbling block for F12 than the kernel version; F12 uses X server 1.7.1, most distros (inc Ubuntu 9.10) are still on 1.6. So it’s still possible this won’t work with F12.

  3. Hi Kulbir,

    I installed the driver 9.11 (what an unlucky number :) and I can confirm that it works with F11 kernel 2.6.30.9-96.fc11.i586. My laptop is the same as in my last post (ASUS X50Z AP-196 with ATI Mobility Radeon HD 3200). I haven’t experienced any issue so far. I will, however, post if something shows up.

    Regards,
    Mx

  4. While it is helpful to have such guides around, one of the new features of F12 is improved Radeon support. Maybe you could also write about that ? :-)

  5. Wes, try the following :

    * to move into another directory use “cd /bla/blabla”

    * to launch a script in a shell use “sh ./nameofthescript”

    * to get the roots right/variable the easy way type “su-” and not just “su”

  6. It doesnt work! I screwed up my working F12 with that shit. Now i must reinstall mesa-GL, etc….etc…etc

    1. Javier,

      It is highly unlikely that you can screw up your Fedora 12 installation with those ATI display drivers. Because in case the driver doesn’t work, just run the command

      $/usr/share/ati/fglrx-uninstall.sh

      and your Xorg.conf and everything else will be restored!!

      1. Kulbir Saini,

        I am having the same problem with F12. I haven’t used Fedora in a while and decided to give it another try. I like what I see so far, but when I installed the ati driver, the logs all looked good, but when I reboot I get a black screen. I tried pressing ctrl+alt+F5 to get a console window, but nothing. The only thing I can do is press the power button and it will gracefully shutdown.

        I haven’t follwed your instructions at http://gofedora.com/how-to-install-ati-catalyst-fglrx-98-drivers-fedora-11/ yet, I am at work and will try these when I get home. Is there anything else I might try?

        1. Kevin,

          Getting to a console to recover the video seems to depend on the kernel that was installed. At least thats the way it’s happening for me.

          I noticed that with the 32-bit 2.6.31.x.PAE kernel (F12 default on multi-core/multi-proc), the ATI kernel module functions well enough for me to switch to a console (I usually use CTRL-ALT-F1, F2, F3… The consoles on F5 and F6 are not always functional for some reason, and F7 is the X session).

          On the 2.6.31.x.x86_64 kernel, however, the ATI driver killed all access to the console screens for me. and I was unable to uninstall the driver without a rescue session. I wrote in below, yesterday, before trying out the x86_64 install again. I had to send a hard “SIGHUP” to the system the same way you did–with the power button.

          I have tried the GoFedora install instructions on the page you linked, and they don’t work for me. I don’t know if it’s video card/chip set related, or if the driver kernel module just does not really function well with the new F12 kernel configurations. And, I don’t have the patience to try recompiling the kernel to get it working.

          —–

          The mesa-dri-drivers-experimental package does work to provide 3D graphics and desktop effects on my Sapphire ATI HD3650. Some here have commented that the acceleration looks choppy, and that is true. Even when scrolling in FireFox, the page scroll is not as smooth as it should be. But, the experimental drivers do function. I am thinking about leaving the experimental mesa drivers there and forgetting about ATI for now.

          If anyone here knows whather my hardware may be to blame, here’s the basic rundown: MSI K9A2 Platinum MOBO w/ AMD 790FX chipset, AMD Phenom 9850 Black Ed., Sapphire HD3650 512MB video.

  7. Ok, just to clarify / double-check, here’s my understanding of what I should do:
    –Option 1 —
    su
    cd /home/Wes/Downloads
    chmod +x ati-driver-installer-9-11-x86.x86_64.run
    ./ati-driver-installer-9-11-x86.x86_64.run

    –Option 2–
    sh /home/Wes/Downloads/ati-driver-installer-9-11-x86.x86_64.run

    –Option 3-from another forum (to try out the built-in F12 drivers instead of ATI official drivers–

    sudo yum -y install mesa-dri-drivers-experimental

    I’m at work now, but I’ll try these out when I get home. Confirmation/corrections requested :-)

  8. Hi There,

    +1 confirmation: FC12(x86_64) + driver downloaded from ati site for HD4850 does not work.

    Did anyone play around with mesa-dri-drivers-experimental?

  9. I tried the mesa-dri-drivers-experimental. I can’t tell that they are any better than installing no drivers at all, as the only 3D app I have installed (Google Earth) is very buggy and jumpy (I’d guess <5 FPS). Though it does allow me to enable compiz-fusion desktop effects.

  10. OK… I have just done a few fresh installs of F12 using a Sapphire HD3650 and these new 9.11 drivers don’t do the trick. Xorg.log shows no driver installed. And, that’s after tweaking the SELinux permissions and tweaking modprobe blacklist and xorg.conf accroding to the instructions above.

    I’m not liking the ATI provided drivers, and I think I’m going to pass on them for a while at least.

    The uninstall script (/usr/share/ati/fglrx-uninstall.sh) did work “swimmingly”, though. So, I have to hand it to ATI to set the system back to “normal” again. NVidia can’t seem to get that much right.

    One note on the mesa-dri-drivers-experimental package. It is working for me. I have compiz functional without the ATI catalyst driver–which is nice.

  11. ati 2400 HD mobility radeon
    I tried the mesa-dri-drivers-experimental on F12 and it works better than no drivers at all. Compiz works now and I’m able to run 3D applications at okay speed. I hope ati fixes their driver to work for F12 soon.

  12. – When I install Catalyst 9.11 on F12 x86_64, I get a “flickering” black screen with a cursor in the upper left, then after a while the flickering stops, and everything is dead. I can boot to single user with grub, though, and the Xorg.log show that fglrxlib.so, I think it was, has an undefined symbol resVgaShared, then it unloads and I get the famous “No drivers available” message.
    – So it seems pretty borked. I only just found that message and haven’t looked for a workaround, but what I’ve read here doesn’t give me a warm fuzzy about finding one.

    – Big thumbs down on functionality here. Haven’t tried the experimental driver yet. I have an nVidia card, maybe I’ll just toss this and give that go? Or maybe try Suse? These drivers are supposed to be compatible with that, but I’ve been using RH/FC since I first installed RH 6, so I’m kinda partial to staying with what I know and like.

    – Gigabit MA790GPT-UD3H mobo, Radeon HD 3300 on-board w/ 12MB “sideport” RAM, Phenom X3 BE, FC12 x86_64 d/led via torrent yesterday. (ratio only up to .22 – crap but this is slow)

    1. I would give the mesa experimental driver a try. It’s working fine for me and the compiz-fusion and fusion-icon packages from the yum repos installed and function without a glitch (except some slow scrolling here and there).

      The only complaint I have is that I cannot get 1600x1200dpi on my AT Radeon HD3650 like I was able to get with F7 and F9 and the ATI drivers.

      I can’t see that my hardware should not be so different from yours that the functionality would be borked: MSI K9A2 Platinum MOBO w/ AMD 790FX chipset, AMD Phenom 9850 Black Ed., Sapphire HD3650 512MB video

      If you really can’t stand the experimental driver functionality, give your nVidia card a try.

      If you’ve only used RH/Fedora, you may not like SuSe. I used to administrate a combined SuSe/RHEL shop and the differences were enough to drive me crazy. The great thing about SuSe is the YaST system administration. I wish RH/Fedora would work on something like this, but YaST was just not enough to warm me up to SuSe. I found it to be much more cranky, and the filesystem org and debian-style tools were just not intuitive to my RH-conditioned brain.

      On the other hand, you might find you like SuSe more than the RH structure.

Comments are closed.